回到顶部

CONTENTS

如何选择合适的 django 版本使用

首先,是不是需要一个地方来查看 django 有没有新版本发布呢,请看:

然后,该如何选择一个合适的版本,是一股脑装最新版(一般都是有 bug 的,很可能和其他库有兼容问题)还是有方法可寻呢,请看:

    一般来说我们都选择在长期维护中的 django 版,即 LTS(Long Term Support) 版本。

官网有个图,很明显的看到某些版本标记了 LTS:

从上图可以看出目前在维护中的 只有两个版本,3.2 版本(还没发布)将要加入 LTS:

  • 1.11(Last version to support Python 2.7.)
  • 2.2(我们 python3 就用 2.2 了,跟 1.11 语法上有些变化,比如:路由的匹配模式

安装的时候指定版本安装就可以安装 LTS 版本(pip install django==2.2.9)


^_^
请喝咖啡 ×

前一篇: django 模板获取 for 循环前 N 条数据
下一篇: django ListView 获取 url 中的参数及根据参数使用不同的模板
captcha
带 * 是必填项